Topic: Textures not showing up for new models in SFC2: CE  (Read 2216 times)

0 Members and 1 Guest are viewing this topic.

Offline isaac.reg

  • Ensign
  • *
  • Posts: 4
Textures not showing up for new models in SFC2: CE
« on: September 19, 2016, 09:49:12 pm »
I've downloaded some new models from several sources and followed the instructions. Most of the time, however, the model shows up in game without textures (solid white), and a handful of times they've showed up with textures but without lightmaps. Any idea what might be going wrong? I'm running Windows 7, if that's relevant. Thanks for your help.

Offline GotAFarmYet?

  • Lt. Commander
  • *
  • Posts: 1191
Re: Textures not showing up for new models in SFC2: CE
« Reply #1 on: September 21, 2016, 02:23:44 am »
Could be lots of issues. Texture names, bit map could be off, image type could be wrong. If converting from a different game type the textures might not be assigned to the model. If you used a SFC v1 ship in OP or EAW the ship will not have light maps and the model will not have them assigned to it, you can not just add them to the folder.

So more info is needed, Link to site or model will help
People always said they wanted the government to listen to them and now the government is listening, taking notes and names...and coming to see you soon!

America-Not the land of the free anymore...
 Its the land of the freeloaders

Remember the axiom of big government bureaucrats: If it moves, tax it. If it keeps moving, regulate it. When, finally, under the crushing weight of taxes and regulation, it stops moving, subsidize it.

Offline isaac.reg

  • Ensign
  • *
  • Posts: 4
Re: Textures not showing up for new models in SFC2: CE
« Reply #2 on: September 26, 2016, 07:49:44 pm »
They're all from here, and made for SFC2. Oddly, they show up fine in the model viewer. Just in the game, the textures are absent. http://demonrenegadestudios.com/drs_fed.html

Offline GotAFarmYet?

  • Lt. Commander
  • *
  • Posts: 1191
Re: Textures not showing up for new models in SFC2: CE
« Reply #3 on: September 27, 2016, 06:32:45 pm »
Ah WZs' stuff

SO you moved the SFC2 model out of the SFC 1 and SFC 2 folder and moved it into the main folder correct?
Next you renamed the SFC 3 version or moved it to the inner folder to get it out of the way?
Can not remember if you have to rename it or not, again been awhile, if so then remove the _SFC2 part but I don't think you have to
might also have to remove the *.gf file, or at least the rename it .old could be the thumbs file (windows hidden)

The mod viewer works for all 3 versions so if the files are there it ignores things the game will not

The file sizes are to small here to try to send you a test ship I know works, so try the above and see what happens
People always said they wanted the government to listen to them and now the government is listening, taking notes and names...and coming to see you soon!

America-Not the land of the free anymore...
 Its the land of the freeloaders

Remember the axiom of big government bureaucrats: If it moves, tax it. If it keeps moving, regulate it. When, finally, under the crushing weight of taxes and regulation, it stops moving, subsidize it.

Offline isaac.reg

  • Ensign
  • *
  • Posts: 4
Re: Textures not showing up for new models in SFC2: CE
« Reply #4 on: September 28, 2016, 12:24:17 am »
I've put the SFC2 file in the main folder with the textures, renamed it, renamed or deleted the SFC3 version, renamed the .gf file extension to .old, deleted it altogether, even tried the SFC1 and SFC3 version in game. They all show up identically - untextured. It's the same for all of WZ's models. In fact, I've only gotten one other model period to show up with textures at all. What else could possibly be wrong? Is something different about the Community Edition that would cause models not to work? Perhaps textures larger than a certain resolution? Thanks for your help. I was surprised anyone responded after this long!

Could you email me the ship you know works with the shiplist directory? isaac.reg at gmail.com
« Last Edit: September 28, 2016, 12:55:13 am by isaac.reg »

Offline GotAFarmYet?

  • Lt. Commander
  • *
  • Posts: 1191
Re: Textures not showing up for new models in SFC2: CE
« Reply #5 on: September 28, 2016, 01:49:38 am »
I've put the SFC2 file in the main folder with the textures, renamed it, renamed or deleted the SFC3 version, renamed the .gf file extension to .old, deleted it altogether, even tried the SFC1 and SFC3 version in game. They all show up identically - untextured. It's the same for all of WZ's models. In fact, I've only gotten one other model period to show up with textures at all. What else could possibly be wrong? Is something different about the Community Edition that would cause models not to work? Perhaps textures larger than a certain resolution? Thanks for your help. I was surprised anyone responded after this long!

Could you email me the ship you know works with the shiplist directory? isaac.reg at gmail.com

Sent a ship I used in the EAW and OP bit of a large file so hope this one makes it have others that are smaller in case this one doesn't do it. I never owned the CE version so not sure on the setup. Since the game is not currently installed I can't send a shiplist. Three things come to mind though
1 the shiplist use to be in 2 places both have to match
2 existing campaigns will not show up changes to the shiplist after a campaign is started it stores info in file that stops that
3 If there is a skirmish mode you verses the AI in a fight it should work there.

The last item would be video drivers but if they show in the model viewer I doubt that as the issue. Someone would help but you might try in the modelling form as Dark Drone might be able to help as well he still makes items for the game. I personally had not been around for Years, and had just stopped by to see if a few ppl were still around. Uses to play around with ship textures, including some of WZ ships. He uses 8-bit encoded textures basically, the ship I sent has a high bit encoding rate. So it is a test to see if it might be video related.
People always said they wanted the government to listen to them and now the government is listening, taking notes and names...and coming to see you soon!

America-Not the land of the free anymore...
 Its the land of the freeloaders

Remember the axiom of big government bureaucrats: If it moves, tax it. If it keeps moving, regulate it. When, finally, under the crushing weight of taxes and regulation, it stops moving, subsidize it.